PHP, which is a recursive acronym for PHP: Hypertext Preprocessor, is one of the most widely used general-purpose scripting languages that are available out there. Any website or web app created with PHP will run on a given server on the condition that a PHP module is installed, which renders the language absolutely universal and it is small wonder that there are actually several million web servers that support it and 100s of millions of PHP-powered sites hosted on them. PHP is preferred over HTML because it allows you to build a dynamic serving site with an immense number of features. A PHP-based community web portal, for instance, will serve unique web content to each visitor even though the page URL will stay the same. On the other hand, HTML sites are static and the page content can be edited only manually. Just like any other piece of software, PHP has several versions and the one that was used while building a given website must be enabled on the web server in order for the site to behave correctly.

PHP 4 and PHP 5 Support in Cloud Web Hosting

In case you buy a cloud web hosting package from us, you will never have to speculate as to whether your sites are compatible with the hosting platform, as different versions of PHP are supported on our servers for the sake of your convenience. The Hepsia Control Panel will permit you to select PHP 4, 5.2, 5.3, 5.4 or 5.5 with only one click and in case you would like to change the version, the new settings will be applied instantaneously. In this way, years of work on sites created with an older version won’t be lost. Our web hosting platform will even allow you to use a different version of PHP for each domain hosted in your account, which means that you can use older and newer scripts at the same time. Most hosting providers on the market support one, sometimes two PHP versions. In stark contrast with them, we believe that you should be the one to pick the version that will be used by your very own sites.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Even if your websites were created with an older version of PHP, you will be able to host them in a semi-dedicated server account from us, as we support multiple versions running at the same time on our servers and each of them can be enabled for your account with just a click through our custom Hepsia Control Panel. Besides the newest PHP 5.4 and PHP 5.5, we also offer 5.3, 5.2 and the older PHP 4, which has already been abandoned by the majority of hosting companies, but we reckon that you shouldn’t be forced to modify a site that took several years to build, since older scripting language syntax does not always mean safety flaws. On the contrary, an adequately maintained website using PHP 4 can be more secure than an improperly maintained one using PHP 5. For the sake of your convenience, we will also give you the opportunity to select a different version of PHP for each single site within the account.